Back to overview
Maintenance

Update - Cloud.spanning.no

Jun 22, 2026 at 11:45am UTC  –  Jun 22, 2026 at 12:45pm UTC
Affected services
Control Panel

Resolved
Jun 22, 2026 at 12:45pm UTC

Maintenance ended

Created
Jun 22, 2026 at 11:45am UTC

Updating our control panel to the newest version